Airgeddon interface problems

(some info that might me usefull:
I’m currently using tp-link tl-wn722n v2 wi-fi adapter
I’m running linux debian on VirtualBox
I haven’t added the adapter in the USB settings (of this virtual machine), but it still works on my pc (I don’t need it, I have built-in wi-fi card) and in the VirtualBox
VirtualBox is running on Windows 8.1)

Soo… after opening Airgeddon it says “choose interface:” and there is only one interface named “eth0 // Chipset: Intel Corporation 82540EM” and after picking it it says “Interface eth0 was choosen. Mode: (non wifi card)” and I cannot start the monitor mode because “Interface eth0 is not a wifi card. It does not support monitor mode”
Any ideas how to fix it? :frowning:
(I think I should add the wifi adapter to USB part in settings, and that would fix that, but I don’t think that’s the problem because I can use internet (In that virtual machine of course) after connecting the adapter to my home wifi in my pc settings)