Anonymity with macchanger

Hello , I’m stuck with an obfuscation about the macchanger … whenever I turn on the macchanger to randomize my Mac address …I’m unable to connect to the internet but when I switch it to my permenant address then it’s performing the handshake connecting to internet …I think it’s because of DHCP of my ISP is refusing to provide the connection to the randomize address …if i change my DNS nameserver will it work…? little help by answering this will be appreciatable…

@J4ck5p4rr0w Try disconnecting from the internet before macchanger. Then reconnect to the internet after you spoof your mac address. If that still does not work give me more info about your network, router, operating system, connected Wlan or Etho. How you are doing it? More info is better on troubleshooting.

1 Like

@MoNsTeR Thanks for replying
I’ve been using Parrot Security OS in vm virtual box in my Windows 7 operating system …then I’m providing the internet connection to my system via my mobile hotspot with usb dongle… virtualbox extensions are included with the vm
Connecting to network through eth0 interface …
I’ve tried some possibilities on my side to change Mac address with macchanger.I think my ISP’s DHCP server is refusing to provide the connection to randomize Mac address. Help needed . I’ve been also searching in Google to fix it up.

I do not use Parrot OS but this is interesting to me. I have a few things to do today. When I get free time tonight I will mimic your setup and see if I can figure out the issue. Off the top of my head I am thinking your phone and dongling is the issue as your phone has a mac address already and since you are dongling through it and changing your mac. Try using hotspot on your phone connect to wifi hotspot after changing mac. What type of phone is it and what provider are you using?


I think that VirtualBox does not allow to change the MAC address, since it is not real. You can change the “fake” mac address in the VM configuration.


If you want to change the address of the USB dongle change the USB configuration of the VM to add your dongle. Then choose the right network interface, “wlan0” in my case.

are you using the vitrual ethernet card as nat or bridge? try using nat to discard the usb dongle

@J4ck5p4rr0w I’m home now. I am just waiting on your reply. Also please try the suggestions from @magohole4 and @alcg101 before I invest more time into this issue. Do follow up with us.

@MoNsTeR @magohole4 @alcg101 I’m unable to surf the internet without dongle because it’s not laptop I’m using the desktop PC … I’ve installed the dongle drivers in my computer and I’ve been using the internet like this for 2 years…but the hurdle is I’m unable to change my Mac with macchanger …and my ISP is reliance Jio.In my VM and details about by network settings is VM briged adapter

@magohole4 i’ve tried in that way too!

@J4ck5p4rr0w Try changing the mac-address from the physical phone itself and see if that works.

1 Like

@MoNsTeR nothing works bro! Porbably I should keep working on it…thanks for all your help…cheers

@J4ck5p4rr0w Does your dongle have drivers for linux?

1 Like

@magohole4 nope .it doesn’t have any drivers to Linux I think but I’m surfing the internet by switching up my VM network configuration at bridged adapter…

@J4ck5p4rr0w I think you need a Linux-compatible USB dongle

1 Like

@MoNsTeR @magohole4 macchanger is isn’t working for me i’ve tried all the possibilities the connection is refusing to perform handshake because of my annoying ISP probably i think.i can able to change my macaddress but i unable to access the internet now i’m gonna switch my DNS to cloudfare and figure it out!