Yesterday i was working on my parrot pen testing Linux distro and I had a plan to play around with creating some backdoor using msfvenom.but unfortunately I unable to access any of the metasploit-framework payloads and not even able to open the msfconsole . abruptly this appears in my CLI *cannot load such file – bundler/setup * and also tried to troubleshoot the error by uninstall and installing the Ruby gems & same to the bundler …a little help will be appreciatable

Have you tried upgrading the Metasploit packages to V5? or are you experiencing this after?

1 Like

@HackerSploit yes! I’m facing this even after upgrading my packages …I’ve also used msf5 but recently I’m struggling with this kinda hurdles.

Alright, could you post a screenshot

1 Like

Yes absolutely!! Thanks for the help. just a moment

Here it is,

I’ve also tried some of the suggestion from stack overflow and etc… by reinstalling the Ruby gems and bundles but nothing worked.:hot_face:

I will ask the obvious in rule it out but did you begin postgresql?

1 Like

I’ve tried that too (postgresql service)

Try reinstalling the bundler:

gem install bundler

or purge metasploit and reinstall afresh, use the synaptic package manager, it should make it easier.

1 Like

I did it bro!.. But it isn’t working

I don’t knkw what kind of resources you have available but I would recommend setting up a VM with the apecific Parrot OS image file and see if the problem replicates on that VM. Curious to see if in some Frankensteinish way msf eas an issue.

1 Like

@binary_rookie sorry, i don’t understand what are you asking precisely ? Would you pls ask the query little bit clearly.

If you have enough RAM, HDD space and CPU setup a Virtual Machine with the specific Parrot OS image file and see if the problem exists on the new installation.

1 Like

@J4ck5p4rr0w Hi jack follow this tutorial to uninstall completely
Then restart Parrot-OS and follow this tutorial to install it back make sure you add an exception on your host system and network if you use windows defender or any antivirus on your host machine if you have it installed on a virtual machine. Follow every step closely and it will work.


@MoNsTeR thanks 4 yr suggestion. I will be working on it

@J4ck5p4rr0w Great. Post back and let us know the results.

I also face this problem in Metasploit Framework 5.0.13 after upgrading to 5.0.14 it solved. If it doesn’t work i have another trick that can completely fix this issue

@Vishu97091 Share your trick. I am interested. Thanks an advance.

Recently , there are too many compatibility issues with my host operating system.I couldn’t even able to install the common third party applications in my Windows 7 I switched up to windows 10 .I got .NET frame work upgraded and l got rid off from those issues…