Please help, Live USB or HDD install of kali, Shutdown issue

I can Not get any tool based live USBs to shutdown properly, except Ubuntu on my laptop, they seem to shutdown but keep power until i hold the power button down, then i can reboot.

I have tried installing Kali to HDD and got ACPI errors before the same problem occurs, I do not get this error when i shutdown just from live USB.

since then i’ve tried numerous usbs, parrot, Kali32, kali kde, parrot kde, black arch, all hacking OSs do the same thing.
I can’t run virtual box smooth enough on my laptop
can someone please please point me in the right direction

This hangs for about 2 minutes then shuts off but whats holding power after shutdown? i’ve been searching and searching for a solution…

@Danman Sounds like it is not un-mounting properly. Try to take a look at the script in /usr/lib/live/mount . Is your system fully encrypted? If not then try this bash script and tell me if it helps.


    command_exists () {
    type "$1" &> /dev/null


    if command_exists udevadm; then
        CMD="$(which udevadm) info -q all -n"

    if command_exists udevinfo; then
        CMD="$(which udevinfo) -q all -n"

    echo "The udevinfo command for this system is $CMD"

    for disk in /dev/sd*
        DISK=$($CMD $disk | grep ID_BUS)
        if [[ "$DISK" == *usb ]]; then
                echo "$disk is USB, now unmounting.."
                umount $disk

@MoNsTeR I havnt bothered trying to encrpt anything yet since i wanna resolve this issue, I ran your script and now getting umount fail of /run/live/medium on both my usbs.
because im not worried about loosing anything i just want a clean base to start from would you suggest another DD if=/dev/zero of=/dev/sda and reset of cmos from battery would give me a better chance?
Just strange i put the usb into my desktop and it shuts down fine. hardware issue of my laptop ? i dunno.

Thank you for your detailed reply i defently want to learn more about bash scripts now.
I need to resolv my laptop issue since i want portability with my exploitable pi
Im updating a persistent usb to see if that helps first.

If the issue is still persistent, you can use the halt command.
halt -t

ok i’ll try -t and look up what the agument is, i have tried halt -h. light still stays on… until you hold power button after shutdown.

I’ve just updated the bios from 314(2016) > 325(2019) I just tried a KDE version by mistake and it loaded and shutdown quick with no errors just the light on the computer still does the same thing like monster said its not unmounting.

been a fun journey anyways, thanks for the input, i appreciate it alot.

1 Like

@Danman Way to stay with it Dan. That is the absolute best way to learn. Investigate then trial and error and repeat. Good job! Forget the quote “Practice Makes Perfect” . The correct quote is “Perfect Practice Makes Perfect.”